Hobby, 3D, Relief, CNC  

[ Új üzenetek · Tagok · Fórumszabályzat · Keresés · RSS ]
Oldal 10 / 11«12891011»
A fórum moderátora: KisKZ, Sir-Nyeteg, Tomi, csewe 
Fórum » HOBBYCNC » HobbyCNC vezérlő szoftverek » MACH3 (MACH3)
MACH3
KisKZ Dátum/Date: Szerda, 2010-12-29, 21:12 | Üzenet/Post # 1
alapkő
Csoport/Group: Adminisztrátorok
Üzenetek/Posts: 3072
Kitüntetések/Medals: 4
Hírnév/Fame: 9
Helyzet/Status: Offline
.
.
Az egyik legelterjedtebb, viszonylag olcsó Windows alapokon futó CNC vezérlő szoftver.
 
Béni Dátum/Date: Péntek, 2014-04-25, 14:37 | Üzenet/Post # 181
Fontos tag
Csoport/Group: Adminisztrátorok
Üzenetek/Posts: 658
Kitüntetések/Medals: 6
Hírnév/Fame: 3
Helyzet/Status: Offline
Készítettem egy leírást a  Mach3 Brain szerkesztésről. Példákkal együtt letölthető:

http://benishare.weebly.com/mach3-brain.html


http://dotg.weebly.com/
http://benishare.weebly.com/
 
tweakie Dátum/Date: Péntek, 2014-04-25, 17:08 | Üzenet/Post # 182
alapvető tag
Csoport/Group: Adminisztrátorok
Üzenetek/Posts: 972
Kitüntetések/Medals: 6
Hírnév/Fame: 5
Helyzet/Status: Offline
Szép munka Beni. 

Tweakie.


Success consists of going from failure to failure without loss of enthusiasm.
 
Béni Dátum/Date: Péntek, 2014-04-25, 17:26 | Üzenet/Post # 183
Fontos tag
Csoport/Group: Adminisztrátorok
Üzenetek/Posts: 658
Kitüntetések/Medals: 6
Hírnév/Fame: 3
Helyzet/Status: Offline
tweakie,  köszönöm!  hello

http://dotg.weebly.com/
http://benishare.weebly.com/
 
Tapti Dátum/Date: Szombat, 2014-05-10, 07:07 | Üzenet/Post # 184
kezdő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 22
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
Idézet KisKZ ()
"..Ha alapból Exact stop üzemben van a Mach, így egy kis értékű gyorsulás nagyon visszafogja a gépet.Másik lehetséges ok ha a Mach nem olvas eléggé előre. Jártam már hasonlóan, ha jól emlékszem a Mach
alapbeállítása 20, ezt 200-ra növelve látványosan gyorsult a gép a részletes megmunkálásoknál.


Az első körben ArtCam topikban, majd azt a Vezérlőszoftver problémákhoz áthelyezett általam említett probléma taglalására sok megoldási lehetőség mutatkozott. De látom, hogy itt volt hasonló dolog tárgyalva. Miután végigolvastam ezt a pár oldalt arra jutottam, hogy én is elvégzem az idézetben szereplő változtatásokat, valamint szintén ezen oldalakon tárgyaltak alapján a  képernyővédőt kikapcsoltam és nem porszívózzuk  a  forgácsot, munka közben marad az ecset és a kefe, az csak nem zavar be.
 
Béni Dátum/Date: Szombat, 2014-05-10, 07:20 | Üzenet/Post # 185
Fontos tag
Csoport/Group: Adminisztrátorok
Üzenetek/Posts: 658
Kitüntetések/Medals: 6
Hírnév/Fame: 3
Helyzet/Status: Offline
Idézet Tapti ()
munka közben marad az ecset és a kefe, az csak nem zavar be.
 A keféléssel is vigyázni kell, mert ... sztatikus feltöltődést is okozhat ...  biggrin


http://dotg.weebly.com/
http://benishare.weebly.com/
 
Dress Dátum/Date: Szerda, 2014-10-08, 13:35 | Üzenet/Post # 186
nézelődő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 14
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
Sziasztok! 

Segítséget szeretnék kérni. Vettem egy jó kis "lézerkeresztet". 
Már fel is aplikáltam a gépre, pazar. 
Raktam egy nyomógombot a Mach3 felületre, nekem tetszik. 
Próbálok Írni hozzá egy scriptet, na ez nem sikerül. 
Ebben kérnék egy kis segítséget. 
Azt szeretném, ha ráállok a munkadarab sarkára és ezt szeretném 0-pontnak, 
csak meg kelljen nyomni ezt a "nyomógombot" és a gép szépen ráállítja a főorsót, lenullázza az X és Y. 

Most itt tartok: 

Xmove = -36.5 'X távolság 
Ymove = -25.0 'Y távolság 

Code "G91 G0 X" &Xmove & "Y" &Ymove 
'While IsMoving () 
'Wend 
Code "G90 M9" 
DoOEMButton (1008) 'X null 
DoOEMButton (1009) 'Y null 

Ha a While és a Wend sorok benne vannak lefagy az egész gép. 

(Ne bántsatok, még sose írtam scriptet. :-) 

Ja, elindul a gép, szépen el is megy a helyére, csak nem nulláz. Ez a problémám.


üdv:
Dress
 
kobee Dátum/Date: Csütörtök, 2015-02-26, 11:31 | Üzenet/Post # 187
ismerkedő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 54
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
Sziasztok!
Lenne egy Mach3-as kérdésem, hátha valaki tudja rá a választ..  Tesztelem a TB6600-as 3 tengelyes vezérlőmet (3axis 5A), egyenlőre az asztalon, motorokkal és laptoppal. Szépen megy is, egyenletesen és simán futnak a motorok, konkrét g-kódot futtatva csinálja rendesen a "marást". Ami a gondom lenne, az az hogy beállítottam a bemeneti PIN-eket, jelzi is a Mach3 hogy épp melyik tengely kerül végállásba, illetve alaphelyzetbe, de ha csinálok egy gépi 0-ra futást akkor az adott motort nem állítja le, pedig kijelzi hogy véghelyzetbe ért. A PIN-ekkel tudok játszani hogy melyik kapcson mi legyen, de eddig még nem tudtam rávenni hogy leálljon ha kell. Az Estop-ot is jelzi, de nem áll meg. De valamelyik végállásra meg megáll, villog a Reset. Valami beállítási hiba lesz, de még nem jöttem rá mi lehet..
 Köszi az esetleges tippeket!
 Üdv.
 
Zolibá Dátum/Date: Péntek, 2015-02-27, 06:28 | Üzenet/Post # 188
alapkő
Csoport/Group: Felhasználók
Üzenetek/Posts: 1267
Kitüntetések/Medals: 6
Hírnév/Fame: 3
Helyzet/Status: Offline
Idézet kobee ()
Lenne egy Mach3-as kérdésem,
Légyszi tedd fel a Mach3Mill.xml filét abból sok minden kiderül.


Az üzenetet módosította/Modified by Zolibá - Péntek, 2015-02-27, 06:33
 
kobee Dátum/Date: Péntek, 2015-02-27, 11:31 | Üzenet/Post # 189
ismerkedő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 54
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
oké, este lesz rá lehetőségem, ha addig nem tudom megoldani, felteszem. Még a tengelybeállításokkal szüttyögök kicsit aztán meglátom. Most már bármelyik (X,Y,Z) alaphelyzet-kapcsolót megnyomva megáll munka közben és villog a Reset. De gépi 0-ra futásnál még nem áll meg, hiába éri el az alaphelyzet kapcsolókat. Egyenlőre...
 Üdv.
    -Z-
 
Zolibá Dátum/Date: Péntek, 2015-02-27, 16:26 | Üzenet/Post # 190
alapkő
Csoport/Group: Felhasználók
Üzenetek/Posts: 1267
Kitüntetések/Medals: 6
Hírnév/Fame: 3
Helyzet/Status: Offline
Idézet kobee ()
De gépi 0-ra futásnál még nem áll meg, hiába éri el az

Ha nyomkodod kézzel a refpont kapcsolókat ez a sárgával jelölt M2-M3 Home villog?
Ez a Diagnosztics fül alatt van.

Valahogy így  kéne kinéznie. (nekem csak refpont kapcsoló van)
Csatolások/Attachments: 4490953.jpg(35Kb) · 9276790.jpg(50Kb)


Az üzenetet módosította/Modified by Zolibá - Péntek, 2015-02-27, 16:29
 
kobee Dátum/Date: Péntek, 2015-02-27, 18:43 | Üzenet/Post # 191
ismerkedő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 54
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
Nekem is jelzi most ha a refpont-kapcsolókat nyomkodom. Az X-refpontot állítottam X mínuszra, és így tovább az Y és Z-nél. Így Xnél villog az X-home és X-limit, és így az Y-nál és Z-nél is. Azaz a Refpont ugyanaz mint a mínusz végállás. Most már meló közben bármelyik megnyomásánál megáll, villog a Reset, és azt kilőve folytatható a munka. Estopnál is megáll, jelzi is. De gépi 0-ra még mindig nem áll. Kettőt egyenként megnyomva nem áll le egyik motor sem, a harmadiknál meg mind megáll és villog a Reset.
 Azt még hozzátenném, hogy ki akartam próbálni magasabb feszültséggel, mivel a leírásában az van hogy 12-48V-ig lehet rá tápfeszt rakni. Gondoltam én 40V-al kipróbálom, de ettől úgy elfüstölt a végfok hogy ihaj.. Szerencsére egyik végfok cseréje 2700Ft-ért megoldotta a dolgot, detalán lett valami maradandó károsodása? Most már kibékültem a 24V-al, az a másik gépnél bevált.. Amúgy a másik gépem H2-es profilját raktam rá, és módosítottam amit írt a leírása az újnak. Most nincs több ötletem. Elküldök egy korábbi beállítást, azóta állítottam a bemeneti Pin-eken, de mindih nem jó..
 Köszi ha esetleg van valami tipped! 
  Üdv.
   -Z-
Csatolások/Attachments: 6560022.xml(113Kb)
 
Zolibá Dátum/Date: Péntek, 2015-02-27, 21:29 | Üzenet/Post # 192
alapkő
Csoport/Group: Felhasználók
Üzenetek/Posts: 1267
Kitüntetések/Medals: 6
Hírnév/Fame: 3
Helyzet/Status: Offline
Idézet kobee ()
De gépi 0-ra még mindig nem áll.
Nézd meg a mellékelt képet, és próbáld ki hogy azonos(X-:X+:és Xref) 1pinre kösd.

Vagy ha 1 van csak


Úgy látom keresztbe kötötted őket. Ez a te  .xml -ben  van.
Csatolások/Attachments: 8117587.jpg(27Kb) · 0838818.jpg(33Kb) · 7440419.jpg(22Kb)


Az üzenetet módosította/Modified by Zolibá - Péntek, 2015-02-27, 21:36
 
kobee Dátum/Date: Péntek, 2015-02-27, 21:45 | Üzenet/Post # 193
ismerkedő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 54
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
Na, Zolibá!
Kicseréltem a vezérlőt egy másikra, mivel kettőt vettem, de az is azt csinálja. Tehát nem sérült meg, így visszaraktam az előzőt. Tehát amit csinál, még 1x: Alaphelyzet kapcsolók leállítják munka közben, X, Y és Z is, és villog utána a Reset.  Gépi 0-ra állásnál ha X-et vagy Z-t nyomok, -mintha elérte volna a Home-ot, nem csinál semmit, megy tovább. Viszont Y-nál meg mindhárom motort leállítja. Az Estop működik, bár nem úgy mint a H2-es vezérlőnél volt. Ott sorba kötöttem a 3 vég-szenzorral, így azokat is Estopnak érzékelte. Ennél viszont amíg be van nyomva a vég-kapcsoló, mintha kiment volna a végéig, addig nem lehet a Resetet törölni. Vagyis így nem tudnék lemenni róla csak kézzel tekerve. A tengelyeket is belőttem, forgásirányt és Home-helyeket tekintve, mintha a gépen lenne, mindet úgy állítottam be. A Dro-ban is jó irányba számol.. Most csak ennyire mentem..  smile

Hozzáadva (2015-02-27, 21:42)
---------------------------------------------
Úgy kötöttem, hogy az XHome és X- egy pin-en van. Ugyanígy az Y és Z-nél. A felső végállások meg az Estop-al vannak sorba kötve.. Xref kapcsolóm nincs, csak a végállások. 3 Pin a 3 Home-nak, egy meg a 3 vég+Estop-nak. A másik gépemen H2-es vezérlővel így műxik.

Hozzáadva (2015-02-27, 21:45)
---------------------------------------------
És van kis eltérés a vezérlőhöz kapott papír, és egy netről letöltött leírás között. Más-más az input-pinek kiosztása. Ha a kapott rajz szerint kötöm be, akkor össze vannak keveredve a kapcsolók. Azt csináltam hogy megnéztem a Mach3 melyiket látja X-nek Y-nak és Z-nek, és úgy kötöttem rá a kapcsolókat. Az Estopra is igaz ez.

 
Zolibá Dátum/Date: Péntek, 2015-02-27, 21:48 | Üzenet/Post # 194
alapkő
Csoport/Group: Felhasználók
Üzenetek/Posts: 1267
Kitüntetések/Medals: 6
Hírnév/Fame: 3
Helyzet/Status: Offline
Idézet kobee ()
Kicseréltem a vezérlőt egy másikra, mivel kettőt vettem, de az is azt csinálja.
Ez nem a vezérlő hibája,rosszul vannak a pinek párosítva, ha jó az .xml amit küldtél

Az X++=13-as de az X- és az X home az 12-es pin. Én ezt sejtem a hiba forrásának.
Ez a szabvány bekötése a párhuzamos portnak

Tehát te a 10,11,12,13,és a 15-ös pinnel gazdálkodhatsz, csak ezek a bemeneteid.
Csatolások/Attachments: 3209929.jpg(33Kb) · 3671290.jpg(29Kb)


Az üzenetet módosította/Modified by Zolibá - Péntek, 2015-02-27, 21:55
 
kobee Dátum/Date: Péntek, 2015-02-27, 21:50 | Üzenet/Post # 195
ismerkedő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 54
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
Azt hiszem holnap fogom csak megpróbálni az előző tippet, amit köszönök is! Addig is alszom rá 1et..  
 További minden jót!  smile
  Üdv.
   -Z-
 
Zolibá Dátum/Date: Péntek, 2015-02-27, 21:54 | Üzenet/Post # 196
alapkő
Csoport/Group: Felhasználók
Üzenetek/Posts: 1267
Kitüntetések/Medals: 6
Hírnév/Fame: 3
Helyzet/Status: Offline
Idézet kobee ()
holnap fogom csak megpróbálni
Használsz valamilyen csatolót is a sz.gép és a vezérlő közt?
Szia.
 
kobee Dátum/Date: Péntek, 2015-02-27, 21:58 | Üzenet/Post # 197
ismerkedő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 54
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
Na ezt még gyorsan megnéztem..  Az X++ nak másnak is kell lennie mint az X- és Xhomenek, nem? Akkor tudja megkülönböztetni az alaphelyzetet a véghelyzettől. Legalábbis H2-nél így ment ez. De még átnézem párszor, köszi szépen!  Amit küldtem xml-t, az még az előző beállítás szerinti, ahol ugyanígy nem ment a gépi 0-ra állás. Most is ez van, csak átrendeztem a pin-eket, és szintén nem áll 0-ra..  smile   Node most mennem kell..  Holnap visszatérek..  Jó éjt!

Hozzáadva (2015-02-27, 21:58)
---------------------------------------------
ja, igen, van egy UC100 is közötte, amit sztem jól megy..  no mentem....  smile

 
Zolibá Dátum/Date: Szombat, 2015-02-28, 05:20 | Üzenet/Post # 198
alapkő
Csoport/Group: Felhasználók
Üzenetek/Posts: 1267
Kitüntetések/Medals: 6
Hírnév/Fame: 3
Helyzet/Status: Offline
Idézet kobee ()
igen, van egy UC100 is közötte, amit sztem jól megy.
Ezzel az USB-s eszközzel nincs tapasztalatom,nem ismerem, én a hagyományos LPT-t feltételeztem.
 
kobee Dátum/Date: Szombat, 2015-02-28, 06:14 | Üzenet/Post # 199
ismerkedő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 54
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
Ez lényegében egy LPT-csatlakozóba épített elektronika, sima USB-ből csinál LPT-t. A másik gépemen is az van, azóta megy normálisan és zajmentesen. Amikor felraktam rá, akkor tudtam gyorsítani is rajta, 3000-el is tud marni ha kell. Van neki 1sec. pufferje is, és megszünteti a számítógép felől jövő zavaró jeleket, átveszi a számolást a laptoptól. Én úgy vagyok vele hogy ez alapból kell.. Tud menni 25, 50, és 100 kHz-en is, függetlenül attól hogy mi van beállítva a port and pins menüben. Van egy feltelepülő pluginja, ami megjelenik fent a menük közt. A gépem most 50 kHz-en megy, simán futnak a motorok. Csak hát ez a kis gond akadt.  A másik gépen a H2-es vezérlőhöz a Magi István féle beállítást használtam a bemenetekhez. Ott megy rendesen..
 No, csak így hirtelen írtam pár szót róla.. Ezután fogok még csak foglalkozni vele..  
 További szép napot!  smile

Hozzáadva (2015-02-28, 06:14)
---------------------------------------------
Ja, és az LPT-pineket ugyanúgy kell beállítani mint sima LPT esetén.

 
kobee Dátum/Date: Szombat, 2015-02-28, 10:27 | Üzenet/Post # 200
ismerkedő tag
Csoport/Group: Felhasználók
Üzenetek/Posts: 54
Kitüntetések/Medals: 0
Hírnév/Fame: 0
Helyzet/Status: Offline
Na mostanra sikerült beállítanom nagggyából..  Mindhárom alaphelyzet-kapcsoló leállítja ha belefut, és jelzi is a Mach3. A véghelyzet-kapcsolók külön,  pin-t kaptak, és az is leállítja ha kell, jelzi is a Mach.  Az Estop megint másik pin-en van, ami szintén működik és leállítja. Így mind az 5 pin fel van használva.
 Mellékelem azért az ábrát és a profilt..

Hozzáadva (2015-02-28, 08:46)
---------------------------------------------
-már csak a gépi nullát nem akarja érzékelni..

Hozzáadva (2015-02-28, 10:27)
---------------------------------------------
Zolibá, az általános segítségkérés-rovatba tettem a folytatást, hátha ott többen látják..
Köszönöm a tippeket! Amit tudtam beállítottam, érzékel mindent, le is áll véghelyzetekben, csak a gépi 0-t nem akarja. De a többi a másik helyen van..
 Üdv.

Csatolások/Attachments: 5775206.jpg(65Kb)
 
Fórum » HOBBYCNC » HobbyCNC vezérlő szoftverek » MACH3 (MACH3)
Oldal 10 / 11«12891011»
Keresés:

Copyright HobbyCnCArt © 2016